CVE-2026-42050 ImageMagick: Stack buffer overflow in XTileImage
A stack buffer overflow in ImageMagick allows attackers to execute arbitrary code or cause denial of service via a malicious MIFF file.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-42050?
CVE-2026-42050 is a medium-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 11 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-21 and 6.9.13-46, a malicious MIFF file could trigger an overflow when a user opens it in the display tool and right-clicks a tile to invoke the Load / Update menu item. This vulnerability is fixed in 7.1.2-21 and 6.9.13-46.
Weakness: CWE-121
Which versions are affected by CVE-2026-42050?
It affects 1 product.
Linux distribution packages (4)
GraphicsMagick SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 1.3.42-150600.3.27.1 |
GraphicsMagick openSUSE:Leap 16.0 | All versions | 1.3.45-160000.7.1 |
GraphicsMagick openSUSE:Tumbleweed | All versions | 1.3.46-7.1 |
ImageMagick openSUSE:Tumbleweed | All versions | 7.1.2.22-1.1 |
Products include Imagemagick Imagemagick.
How do I fix CVE-2026-42050?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-42050 being exploited?
There is no known exploitation of CVE-2026-42050 in the wild and no public exploit code.
Other vulnerabilities in Imagemagick Imagemagick
Sources
Also known as CLSA-2026-1779127347, CLSA-2026-1779127684, CLSA-2026-1779128088, CLSA-2026-1779128854, CLSA-2026-1779129021, CLSA-2026-1779193855 and 19 more.