CVE-2026-42051 Kirby: System API endpoint leaks license data and installed version to authenticated users
Authenticated users can access sensitive license data and version information via the system API endpoint in Kirby CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42051?
CVE-2026-42051 is a medium-severity vulnerability in getkirby kirby, published on 9 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kirby is an open-source content management system. Prior to versions 4.9.0 and 5.4.0, the system API endpoint leaks license data and installed version to authenticated users. This issue has been patched in versions 4.9.0 and 5.4.0.
Weakness: CWE-862
Which versions are affected by CVE-2026-42051?
4 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.0 |
getkirby/cms Packagist | All versions | 4.9.0 |
getkirby/cms Packagist | From 5.0.0 | 5.4.0 |
getkirby/cms Packagist | From 5.0.0 | 5.4.0 |
Products include Getkirby Kirby.
How do I fix CVE-2026-42051?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.0 or 5.4.0.
Is CVE-2026-42051 being exploited?
There is no known exploitation of CVE-2026-42051 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-x68m-c7jf-2572.