# CVE-2026-42051: Kirby: System API endpoint leaks license data and installed version to authenticated users

> Authenticated users can access sensitive license data and version information via the system API endpoint in Kirby CMS.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-x68m-c7jf-2572

## What is CVE-2026-42051?

CVE-2026-42051 is a medium-severity vulnerability in getkirby kirby, published on 9 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is an open-source content management system. Prior to versions 4.9.0 and 5.4.0, the system API endpoint leaks license data and installed version to authenticated users. This issue has been patched in versions 4.9.0 and 5.4.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-42051?

4 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.0 |
| `getkirby/cms` | Packagist | All versions | 4.9.0 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.0 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.0 |

Products: Getkirby Kirby.

## How do I fix CVE-2026-42051?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.0 or 5.4.0.

## Is CVE-2026-42051 being exploited?

There is no known exploitation of CVE-2026-42051 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42051 and fix it if it is affected.

What it is: CVE-2026-42051 is a medium-severity vulnerability in getkirby kirby, published on 9 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42051 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.0
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.0
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.0
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42051/ (Markdown: https://insights.sbomify.com/CVE-2026-42051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42051
- OSV: https://osv.dev/vulnerability/CVE-2026-42051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42051/
Summaries are generated and may contain mistakes; the official description above is the record.
