{"answers":{"affected":"3 open source packages ship an affected version, including beets.","exploited":"There is no known exploitation of CVE-2026-42052 in the wild and no public exploit code.","fix":"Upgrade beets to 2.10.0 or later.","what":"CVE-2026-42052 is a medium-severity cross-site scripting vulnerability in beetbox beets, published on 4 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42052 and fix it if it is affected.\n\nWhat it is: CVE-2026-42052 is a medium-severity cross-site scripting vulnerability in beetbox beets, published on 4 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-42052 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- beets (PyPI): affected all versions; fixed in 2.10.0\n- beets (PyPI): affected all versions; fixed in 2.10.0\n- beets (PyPI): affected all versions; fixed in 2.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42052/ (Markdown: https://insights.sbomify.com/CVE-2026-42052/index.md)","id":"CVE-2026-42052","markdown":"https://insights.sbomify.com/CVE-2026-42052/index.md","name":"CVE-2026-42052","record":{"aliases":["DEBIAN-CVE-2026-42052","GHSA-3gxm-wfjx-m847","PYSEC-2026-2397","UBUNTU-CVE-2026-42052","USN-8747-1","openSUSE-SU-2026:10865-1","openSUSE-SU-2026:21383-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Media library manager","requires_auth":"none","summary":"An attacker can inject malicious scripts into the web UI via untrusted metadata fields, potentially executing code in the victim's browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Beets is the media library management system. Prior to version 2.10.0, the bundled web UI uses Underscore template interpolation mode \u003c%= ... %\u003e for untrusted metadata fields. In this runtime, \u003c%= ... %\u003e is raw insertion and HTML escaping is only performed by \u003c%- ... %\u003e. Rendered output is then inserted with .html(...), allowing attacker-controlled markup to become active DOM. This issue has been patched in version 2.10.0.","ecosystems":["PyPI","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"beets is Vulnerable to XSS","id":"CVE-2026-42052","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":5,"n_references":2,"next":{"headline":"NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability","id":"CVE-2026-42055"},"packages":[{"ecosystem":"PyPI","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"beets","purl":null,"source":"GHSA-3gxm-wfjx-m847"},{"ecosystem":"PyPI","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"beets","purl":"pkg:pypi/beets","source":"GHSA-3gxm-wfjx-m847"},{"ecosystem":"PyPI","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"beets","purl":"pkg:pypi/beets","source":"PYSEC-2026-2397"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["2.2.0-bp160.2.1"],"introduced":["0"],"last_affected":[],"package":"beets","purl":"pkg:rpm/opensuse/beets\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21383-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.11.0-1.1"],"introduced":["0"],"last_affected":[],"package":"beets","purl":"pkg:rpm/opensuse/beets\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10865-1"}],"prev":{"headline":"Kirby: System API endpoint leaks license data and installed version to authenticated users","id":"CVE-2026-42051"},"products":["beets"],"published":"2026-05-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["beetbox"]},"summary":"An attacker can inject malicious scripts into the web UI via untrusted metadata fields, potentially executing code in the victim's browser.","url":"https://insights.sbomify.com/CVE-2026-42052/"}