# CVE-2026-42071: MantisBT: Private Bugnote Attachment Content Leak via REST API

> Authenticated users can download private bugnote attachments via API endpoints due to missing authorization checks in MantisBT.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-pw5x-2mf9-3xc8

## What is CVE-2026-42071?

CVE-2026-42071 is a high-severity missing authorization vulnerability in mantisbt, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. From 2.23.0 to 2.28.1, a missing authorization check in MantisBT's file visibility function allows any authenticated user (REPORTER+) to download attachments on private bugnotes they should not be able to access, via the REST API endpoint GET /api/rest/issues/{id}/files and SOAP API mc_issue_attachment_get endpoint. This vulnerability is fixed in 2.28.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-42071?

2 open source packages ship an affected version, including mantisbt/mantisbt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | From 2.23.0 | 2.28.2 |
| `mantisbt/mantisbt` | Packagist | From 2.23.0 | 2.28.2 |

## How do I fix CVE-2026-42071?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

## Is CVE-2026-42071 being exploited?

There is no known exploitation of CVE-2026-42071 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42071 and fix it if it is affected.

What it is: CVE-2026-42071 is a high-severity missing authorization vulnerability in mantisbt, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42071 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected from 2.23.0; fixed in 2.28.2
- mantisbt/mantisbt (Packagist): affected from 2.23.0; fixed in 2.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42071/ (Markdown: https://insights.sbomify.com/CVE-2026-42071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42071
- OSV: https://osv.dev/vulnerability/CVE-2026-42071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42071/
Summaries are generated and may contain mistakes; the official description above is the record.
