# CVE-2026-42073: OpenClaude's MCP OAuth Callback: State Check Bypass via error Param Leads to DoS

> Attackers can bypass OAuth state validation in OpenClaude CLI to force a denial of service by shutting down the local authentication server.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-c73c-x77g-854r

## What is CVE-2026-42073?

CVE-2026-42073 is a medium-severity vulnerability in Gitlawb openclaude, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenClaude is an open-source coding-agent command line interface for cloud and local model providers. Prior to version 0.5.1, the OpenClaude MCP authentication flow starts a temporary local HTTP server to handle OAuth callbacks. To prevent CSRF attacks, the server validates a state parameter against an internally stored value. However, due to a logic flaw in the order of conditionals, an attacker can completely bypass this check and force the server to shut down — without knowing the state value at all. This issue has been patched in version 0.5.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-42073?

2 open source packages ship an affected version, including @gitlawb/openclaude. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@gitlawb/openclaude` | npm | All versions | 0.5.1 |
| `@gitlawb/openclaude` | npm | All versions | 0.5.1 |

Products: Gitlawb Openclaude.

## How do I fix CVE-2026-42073?

Upgrade @gitlawb/openclaude to 0.5.1 or later.

## Is CVE-2026-42073 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42073 exists.

## Other vulnerabilities in Gitlawb openclaude

- [CVE-2026-42074](https://insights.sbomify.com/CVE-2026-42074/): OpenClaude: Sandbox Bypass via Model-Controlled `dangerouslyDisableSandbox` Input (critical 9.3)
- [CVE-2026-35570](https://insights.sbomify.com/CVE-2026-35570/): OpenClaude has Sandbox Bypass via Early-Exit Logic Flaw that Allows Path Traversal (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42073 and fix it if it is affected.

What it is: CVE-2026-42073 is a medium-severity vulnerability in Gitlawb openclaude, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42073 exists.

Affected packages and fixed versions:
- @gitlawb/openclaude (npm): affected all versions; fixed in 0.5.1
- @gitlawb/openclaude (npm): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42073/ (Markdown: https://insights.sbomify.com/CVE-2026-42073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42073
- OSV: https://osv.dev/vulnerability/CVE-2026-42073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42073/
Summaries are generated and may contain mistakes; the official description above is the record.
