# CVE-2026-42075: Evolver: Path Traversal via `--out` flag in `fetch` command allows Arbitrary File Write

> Attackers can write arbitrary files to the filesystem via the fetch command's output flag, potentially overwriting critical system files.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-r466-rxw4-3j9j

## What is CVE-2026-42075?

CVE-2026-42075 is a high-severity path traversal vulnerability in EvoMap evolver, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a path traversal vulnerability in the skill download (fetch) command allows attackers to write files to arbitrary locations on the filesystem. The --out= flag accepts user-provided paths without validation, enabling directory traversal attacks that can overwrite critical system files or create files in sensitive location. This issue has been patched in version 1.69.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-42075?

2 open source packages ship an affected version, including @evomap/evolver.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@evomap/evolver` | npm | All versions | 1.69.3 |
| `@evomap/evolver` | npm | All versions | 1.69.3 |

## How do I fix CVE-2026-42075?

Upgrade @evomap/evolver to 1.69.3 or later.

## Is CVE-2026-42075 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42075 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42075 and fix it if it is affected.

What it is: CVE-2026-42075 is a high-severity path traversal vulnerability in EvoMap evolver, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42075 exists.

Affected packages and fixed versions:
- @evomap/evolver (npm): affected all versions; fixed in 1.69.3
- @evomap/evolver (npm): affected all versions; fixed in 1.69.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42075/ (Markdown: https://insights.sbomify.com/CVE-2026-42075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42075
- OSV: https://osv.dev/vulnerability/CVE-2026-42075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42075/
Summaries are generated and may contain mistakes; the official description above is the record.
