# CVE-2026-42079: PPTAgent: Arbitrary Code Execution via Python eval() of LLM-Generated Code with Builtins in Scope

> Attackers can execute arbitrary code by exploiting unsafe eval() usage on LLM-generated content in the PPTAgent library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-89g2-xw5c-v95p, PYSEC-2026-2892

## What is CVE-2026-42079?

CVE-2026-42079 is a high-severity code injection vulnerability in icip-cas PPTAgent, published on 4 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PPTAgent is an agentic framework for reflective PowerPoint generation. Prior to commit 418491a, PPTAgent is vulnerable to arbitrary code execution via Python eval() of LLM-generated code with builtins in scope. This issue has been patched via commit 418491a.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-42079?

3 open source packages ship an affected version, including pptagent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pptagent` | PyPI | All versions | 1.1.36 |
| `pptagent` | PyPI | All versions | 1.1.36 |
| `pptagent` | PyPI | All versions | 1.1.36 |

## How do I fix CVE-2026-42079?

Upgrade pptagent to 1.1.36 or later.

## Is CVE-2026-42079 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42079 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42079 and fix it if it is affected.

What it is: CVE-2026-42079 is a high-severity code injection vulnerability in icip-cas PPTAgent, published on 4 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42079 exists.

Affected packages and fixed versions:
- pptagent (PyPI): affected all versions; fixed in 1.1.36
- pptagent (PyPI): affected all versions; fixed in 1.1.36
- pptagent (PyPI): affected all versions; fixed in 1.1.36

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42079/ (Markdown: https://insights.sbomify.com/CVE-2026-42079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42079
- OSV: https://osv.dev/vulnerability/CVE-2026-42079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42079/
Summaries are generated and may contain mistakes; the official description above is the record.
