# CVE-2026-42083: Free5GC PCF: Missing authentication middleware in Npcf_SMPolicyControl allows access to SM policy handlers and disclosure of subscriber SUPI

> Unauthenticated attackers can access SM policy handlers and disclose subscriber SUPI due to missing authentication middleware in free5GC PCF.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-6rgm-gr97-x3j5, GO-2026-5189

## What is CVE-2026-42083?

CVE-2026-42083 is a high-severity missing authorization vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, PCF Npcf_SMPolicyControl missing authentication middleware allows unauthenticated access to SM policy handlers and disclosure of subscriber SUPI. In NewServer(), the smPolicyGroup route group is created and routes are applied without attaching the router authorization middleware. In contrast, other PCF service groups such as Npcf_PolicyAuthorization do attach RouterAuthorizationCheck before route registration. Because the middleware is missing, requests to the  /npcf-smpolicycontrol/v1/sm-policies, /npcf-smpolicycontrol/v1/sm-policies/{smPolicyId}, /npcf-smpolicycontrol/v1/sm-policies/{smPolicyId}/update, and /npcf-smpolicycontrol/v1/sm-policies/{smPolicyId}/delete endpoints can reach business logic even when no valid OAuth token is provided. This vulnerability is fixed in 4.2.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-42083?

3 open source packages ship an affected version, including github.com/free5gc/pcf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |

Products: Free5gc Free5gc.

## How do I fix CVE-2026-42083?

Upgrade github.com/free5gc/pcf to 1.4.3 or later.

## Is CVE-2026-42083 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42083 exists.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44315](https://insights.sbomify.com/CVE-2026-44315/): free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42083 and fix it if it is affected.

What it is: CVE-2026-42083 is a high-severity missing authorization vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42083 exists.

Affected packages and fixed versions:
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42083/ (Markdown: https://insights.sbomify.com/CVE-2026-42083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42083
- OSV: https://osv.dev/vulnerability/CVE-2026-42083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42083/
Summaries are generated and may contain mistakes; the official description above is the record.
