# CVE-2026-42086: OpenC3 COSMOS: Self-XSS in the Command Sender

> An attacker can execute arbitrary JavaScript in a victim's browser via self-XSS in the Command Sender, potentially stealing session tokens or modifying data.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-ffq5-qpvf-xq7x, PYSEC-2026-105

## What is CVE-2026-42086?

CVE-2026-42086 is a medium-severity cross-site scripting vulnerability in OpenC3 cosmos, published on 4 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. Prior to version 7.0.0, the Command Sender UI uses an unsafe eval() function on array-like command parameters, which allows a user-supplied payload to execute in the browser when sending a command. This creates a self-XSS risk because an attacker can trigger their own script execution in the victim’s session, if allowed to influence the array parameter input, for example via phishing. If successful, an attacker may read or modify data in the authenticated browser context, including session tokens in local storage. This issue has been patched in version 7.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42086?

5 open source packages ship an affected version, including openc3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openc3` | PyPI | All versions | 7.0.0 |
| `openc3` | PyPI | All versions | 7.0.0 |
| `openc3` | PyPI | All versions | 7.0.0 |
| `openc3` | RubyGems | All versions | 7.0.0 |
| `openc3` | RubyGems | All versions | 7.0.0 |

Products: Openc3 Cosmos.

## How do I fix CVE-2026-42086?

Upgrade openc3 to 7.0.0 or later.

## Is CVE-2026-42086 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42086 exists.

## Other vulnerabilities in OpenC3 cosmos

- [CVE-2025-28386](https://insights.sbomify.com/CVE-2025-28386/): Code injection in n/a (critical 9.8)
- [CVE-2025-28388](https://insights.sbomify.com/CVE-2025-28388/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2025-28389](https://insights.sbomify.com/CVE-2025-28389/): Weak cryptography in n/a (critical 9.8)
- [CVE-2026-42087](https://insights.sbomify.com/CVE-2026-42087/): OpenC3 COSMOS: SQL Injection in QuestDB Time-Series Data Base (critical 9.6)
- [CVE-2026-42088](https://insights.sbomify.com/CVE-2026-42088/): OpenC3 COSMOS: Administrative Actions via the Script Runner Tool (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42086 and fix it if it is affected.

What it is: CVE-2026-42086 is a medium-severity cross-site scripting vulnerability in OpenC3 cosmos, published on 4 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42086 exists.

Affected packages and fixed versions:
- openc3 (PyPI): affected all versions; fixed in 7.0.0
- openc3 (PyPI): affected all versions; fixed in 7.0.0
- openc3 (PyPI): affected all versions; fixed in 7.0.0
- openc3 (RubyGems): affected all versions; fixed in 7.0.0
- openc3 (RubyGems): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42086/ (Markdown: https://insights.sbomify.com/CVE-2026-42086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42086
- OSV: https://osv.dev/vulnerability/CVE-2026-42086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42086/
Summaries are generated and may contain mistakes; the official description above is the record.
