# CVE-2026-42088: OpenC3 COSMOS: Administrative Actions via the Script Runner Tool

> Users with script execution permissions can bypass API checks to perform administrative actions, read secrets, and modify system settings.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-2wvh-87g2-89hr, PYSEC-2026-2245

## What is CVE-2026-42088?

CVE-2026-42088 is a critical vulnerability in OpenC3 cosmos, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. Prior to version 7.0.0-rc3, the Script Runner widget allows users to execute Python and Ruby scripts directly from the openc3-COSMOS-script-runner-api container. Because all the docker containers share a network, users can execute specially crafted scripts to bypass the API permissions check and perform administrative actions, including reading and modifying data inside the Redis database, which can be used to read secrets and change COSMOS settings, as well as read and write to the buckets service, which holds configuration, log, and plugin files. These actions are normally only available from the Admin Console or with administrative privileges. Any user with permission to create and run scripts can connect to any service in the docker network. This issue has been patched in version 7.0.0-rc3.

Weakness: CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2026-42088?

3 open source packages ship an affected version, including openc3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openc3` | PyPI | All versions | 7.0.0 |
| `openc3` | RubyGems | All versions | 7.0.0-rc3 |
| `openc3` | RubyGems | All versions | 7.0.0-rc3 |

Products: Openc3 Cosmos.

## How do I fix CVE-2026-42088?

Upgrade openc3 to a fixed version for your release line: 7.0.0 or 7.0.0-rc3.

## Is CVE-2026-42088 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42088 exists.

## Other vulnerabilities in OpenC3 cosmos

- [CVE-2025-28386](https://insights.sbomify.com/CVE-2025-28386/): Code injection in n/a (critical 9.8)
- [CVE-2025-28388](https://insights.sbomify.com/CVE-2025-28388/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2025-28389](https://insights.sbomify.com/CVE-2025-28389/): Weak cryptography in n/a (critical 9.8)
- [CVE-2026-42087](https://insights.sbomify.com/CVE-2026-42087/): OpenC3 COSMOS: SQL Injection in QuestDB Time-Series Data Base (critical 9.6)
- [CVE-2025-28384](https://insights.sbomify.com/CVE-2025-28384/): OpenC3 COSMOS Vulnerable to Directory Traversal via /script-api/scripts/ endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42088 and fix it if it is affected.

What it is: CVE-2026-42088 is a critical vulnerability in OpenC3 cosmos, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42088 exists.

Affected packages and fixed versions:
- openc3 (PyPI): affected all versions; fixed in 7.0.0
- openc3 (RubyGems): affected all versions; fixed in 7.0.0-rc3
- openc3 (RubyGems): affected all versions; fixed in 7.0.0-rc3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42088/ (Markdown: https://insights.sbomify.com/CVE-2026-42088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42088
- OSV: https://osv.dev/vulnerability/CVE-2026-42088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42088/
Summaries are generated and may contain mistakes; the official description above is the record.
