{"answers":{"affected":"2 open source packages ship an affected version, including yeoman-environment.","exploited":"There is no known exploitation of CVE-2026-42089 in the wild and no public exploit code.","fix":"Upgrade yeoman-environment to 6.0.1 or later.","what":"CVE-2026-42089 is a high-severity code injection vulnerability in yeoman environment, published on 16 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42089 and fix it if it is affected.\n\nWhat it is: CVE-2026-42089 is a high-severity code injection vulnerability in yeoman environment, published on 16 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-42089 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yeoman-environment (npm): affected from 2.9.0; fixed in 6.0.1\n- yeoman-environment (npm): affected from 2.9.0; fixed in 6.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42089/ (Markdown: https://insights.sbomify.com/CVE-2026-42089/index.md)","id":"CVE-2026-42089","markdown":"https://insights.sbomify.com/CVE-2026-42089/index.md","name":"CVE-2026-42089","record":{"aliases":["CLSA-2026-1789069708","GHSA-vv9j-gjw2-j8wp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Yeoman environment library","requires_auth":"none","summary":"Attackers can trigger arbitrary package installation and code execution by supplying malicious generator names to the Yeoman environment library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-06-26","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-06-26T12:47:30Z","kind":"github_poc","ref":"https://github.com/0xmrma/CVE-2026-42089","stars":0,"title":"A local package installation helper trusted caller-supplied package names too much. In yeoman-environment, missing generators could be installed without user confirmation, turning attacker-controlled project metadata into a package-install and code-execution path."}],"tier":"poc_unverified"},"has_fix":true,"headline":"yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation","id":"CVE-2026-42089","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Notesnook: RCE via stored XSS in note export rendering","id":"CVE-2026-42090"},"packages":[{"ecosystem":"npm","fixed":["6.0.1"],"introduced":["2.9.0"],"last_affected":[],"package":"yeoman-environment","purl":null,"source":"GHSA-vv9j-gjw2-j8wp"},{"ecosystem":"npm","fixed":["6.0.1"],"introduced":["2.9.0"],"last_affected":[],"package":"yeoman-environment","purl":"pkg:npm/yeoman-environment","source":"GHSA-vv9j-gjw2-j8wp"}],"prev":{"headline":"OpenC3 COSMOS: Administrative Actions via the Script Runner Tool","id":"CVE-2026-42088"},"products":["environment"],"published":"2026-06-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-16","vendors":["yeoman"]},"summary":"Attackers can trigger arbitrary package installation and code execution by supplying malicious generator names to the Yeoman environment library.","url":"https://insights.sbomify.com/CVE-2026-42089/"}