# CVE-2026-42089: yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation

> Attackers can trigger arbitrary package installation and code execution by supplying malicious generator names to the Yeoman environment library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jun 2026
- **Updated:** 16 Jun 2026
- **Also known as:** CLSA-2026-1789069708, GHSA-vv9j-gjw2-j8wp

## What is CVE-2026-42089?

CVE-2026-42089 is a high-severity code injection vulnerability in yeoman environment, published on 16 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-42089?

2 open source packages ship an affected version, including yeoman-environment.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeoman-environment` | npm | From 2.9.0 | 6.0.1 |
| `yeoman-environment` | npm | From 2.9.0 | 6.0.1 |

## How do I fix CVE-2026-42089?

Upgrade yeoman-environment to 6.0.1 or later.

## Is CVE-2026-42089 being exploited?

There is no known exploitation of CVE-2026-42089 in the wild and no public exploit code.

Public exploit code:

- A local package installation helper trusted caller-supplied package names too much. In yeoman-environment, missing generators could be installed without user confirmation, turning attacker-controlled project metadata into a package-install and code-execution path. (github_poc): https://github.com/0xmrma/CVE-2026-42089

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42089 and fix it if it is affected.

What it is: CVE-2026-42089 is a high-severity code injection vulnerability in yeoman environment, published on 16 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42089 in the wild and no public exploit code.

Affected packages and fixed versions:
- yeoman-environment (npm): affected from 2.9.0; fixed in 6.0.1
- yeoman-environment (npm): affected from 2.9.0; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42089/ (Markdown: https://insights.sbomify.com/CVE-2026-42089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42089
- OSV: https://osv.dev/vulnerability/CVE-2026-42089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42089/
Summaries are generated and may contain mistakes; the official description above is the record.
