# CVE-2026-42138: Dify Vulnerable to Stored XSS via SVG-file upload


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-cg94-8v83-7hjj

## What is CVE-2026-42138?

CVE-2026-42138 is a medium-severity vulnerability in langgenius dify, published on 4 May 2026. 

### Official description

Dify is an open-source LLM app development platform. Prior to version 1.13.1, using the method POST /api/files/upload, any unauthenticated user can upload an SVG file with XSS. The method POST /v1/files/upload, which requires authentication through the application API, is also vulnerable. This issue has been patched in version 1.13.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42138?

It affects 1 product.


Products: Langgenius Dify.

## How do I fix CVE-2026-42138?

No fix has been published for CVE-2026-42138 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42138 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42138 exists.

## Other vulnerabilities in langgenius dify

- [CVE-2025-56157](https://insights.sbomify.com/CVE-2025-56157/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2025-3466](https://insights.sbomify.com/CVE-2025-3466/): Unsanitized Input in langgenius/dify (critical 9.8)
- [CVE-2025-63386](https://insights.sbomify.com/CVE-2025-63386/): Misconfiguration in n/a (critical 9.1)
- [CVE-2025-63388](https://insights.sbomify.com/CVE-2025-63388/): Misconfiguration in n/a (critical 9.1)
- [CVE-2024-10252](https://insights.sbomify.com/CVE-2024-10252/): Code Injection in langgenius/dify (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42138 and fix it if it is affected.

What it is: CVE-2026-42138 is a medium-severity vulnerability in langgenius dify, published on 4 May 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42138 exists.

Affected product: langgenius dify. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42138/ (Markdown: https://insights.sbomify.com/CVE-2026-42138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42138
- OSV: https://osv.dev/vulnerability/CVE-2026-42138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42138/
Summaries are generated and may contain mistakes; the official description above is the record.
