# CVE-2026-42140: Server-Side Request Forgery (SSRF) in PlantUML Macro via 'server' parameter

> An attacker can exploit the PlantUML Macro in XWiki to perform Server-Side Request Forgery by supplying unvalidated URLs, potentially accessing internal resources.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-42fc-7w97-8vrc

## What is CVE-2026-42140?

CVE-2026-42140 is a medium-severity server-side request forgery vulnerability in xwiki-contrib macro-plantuml, published on 4 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PlantUML Macro is a macro for rendering UML diagrams from simple textual schemes. Prior to version 2.4.1, the PlantUML Macro is vulnerable to Server-Side Request Forgery (SSRF). The macro allows users to specify an alternative PlantUML server via the server parameter. However, the application does not validate the supplied URL. An attacker can supply an internal IP address or a malicious external URL. The XWiki server will attempt to connect to this URL to "render" the diagram. This issue has been patched in version 2.4.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-42140?

2 open source packages ship an affected version, including org.xwiki.contrib.plantuml:macro-plantuml-macro.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib.plantuml:macro-plantuml-macro` | Maven | All versions | 2.4.1 |
| `org.xwiki.contrib.plantuml:macro-plantuml-macro` | Maven | All versions | 2.4.1 |

## How do I fix CVE-2026-42140?

Upgrade org.xwiki.contrib.plantuml:macro-plantuml-macro to 2.4.1 or later.

## Is CVE-2026-42140 being exploited?

There is no known exploitation of CVE-2026-42140 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42140 and fix it if it is affected.

What it is: CVE-2026-42140 is a medium-severity server-side request forgery vulnerability in xwiki-contrib macro-plantuml, published on 4 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42140 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.contrib.plantuml:macro-plantuml-macro (Maven): affected all versions; fixed in 2.4.1
- org.xwiki.contrib.plantuml:macro-plantuml-macro (Maven): affected all versions; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42140/ (Markdown: https://insights.sbomify.com/CVE-2026-42140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42140
- OSV: https://osv.dev/vulnerability/CVE-2026-42140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42140/
Summaries are generated and may contain mistakes; the official description above is the record.
