CVE-2026-42155 Magento LTS: Weak API Session ID — Predictable MD5 of Time-Derived Inputs

Critical 9.3 Published Updated

Attackers can hijack active API sessions by brute-forcing predictable MD5-based session IDs generated from time-derived inputs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42155?

CVE-2026-42155 is a critical vulnerability in OpenMage magento-lts, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, the XML-RPC / SOAP API session ID is generated using an outdated, time-based construction rather than a Cryptographically Secure Pseudo-Random Number Generator (CSPRNG). All inputs to the MD5 hash are time-derived and non-secure. Because the resulting digest relies entirely on the timestamp and the PHP internal LCG state, the effective entropy is severely constrained. This violates the OWASP ASVS v4 requirement of ≥ 64 bits of entropy (V3.2.2) and NIST SP 800-63B standards. By narrowing the LCG window (via server state leaks or general predictability) and leveraging the lack of API rate-limiting, an attacker can generate a localized pool of candidate MD5 hashes and execute a high-speed online brute-force attack to hijack active API sessions. This vulnerability is fixed in 20.18.0.

Weakness: CWE-338, CWE-331, CWE-330

Which versions are affected by CVE-2026-42155?

2 open source packages ship an affected version, including openmage/magento-lts.

PackageAffectedFixed in
openmage/magento-lts PackagistAll versions20.18.0
openmage/magento-lts PackagistAll versions20.18.0

How do I fix CVE-2026-42155?

Upgrade openmage/magento-lts to 20.18.0 or later.

Is CVE-2026-42155 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42155 exists.

Sources

Also known as GHSA-2cwr-gcf9-pvxr.

Is CVE-2026-42155 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free