{"answers":{"affected":"2 open source packages ship an affected version, including openmage/magento-lts.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42155 exists.","fix":"Upgrade openmage/magento-lts to 20.18.0 or later.","what":"CVE-2026-42155 is a critical vulnerability in OpenMage magento-lts, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42155 and fix it if it is affected.\n\nWhat it is: CVE-2026-42155 is a critical vulnerability in OpenMage magento-lts, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42155 exists.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.18.0\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42155/ (Markdown: https://insights.sbomify.com/CVE-2026-42155/index.md)","id":"CVE-2026-42155","markdown":"https://insights.sbomify.com/CVE-2026-42155/index.md","name":"CVE-2026-42155","record":{"aliases":["GHSA-2cwr-gcf9-pvxr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento LTS","requires_auth":"none","summary":"Attackers can hijack active API sessions by brute-forcing predictable MD5-based session IDs generated from time-derived inputs.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-338","name":"Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)"},{"id":"CWE-331","name":"Insufficient Entropy"},{"id":"CWE-330","name":"Use of Insufficiently Random Values"}],"description":"Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, the XML-RPC / SOAP API session ID is generated using an outdated, time-based construction rather than a Cryptographically Secure Pseudo-Random Number Generator (CSPRNG). All inputs to the MD5 hash are time-derived and non-secure. Because the resulting digest relies entirely on the timestamp and the PHP internal LCG state, the effective entropy is severely constrained. This violates the OWASP ASVS v4 requirement of ≥ 64 bits of entropy (V3.2.2) and NIST SP 800-63B standards. By narrowing the LCG window (via server state leaks or general predictability) and leveraging the lack of API rate-limiting, an attacker can generate a localized pool of candidate MD5 hashes and execute a high-speed online brute-force attack to hijack active API sessions. This vulnerability is fixed in 20.18.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Magento LTS: Weak API Session ID — Predictable MD5 of Time-Derived Inputs","id":"CVE-2026-42155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Flowsint: Cypher query injection in node type on node creation","id":"CVE-2026-42156"},"packages":[{"ecosystem":"Packagist","fixed":["20.18.0"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-2cwr-gcf9-pvxr"},{"ecosystem":"Packagist","fixed":["20.18.0"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-2cwr-gcf9-pvxr"}],"prev":{"headline":"Prometheus: remote read endpoint allows denial of service via crafted snappy payload","id":"CVE-2026-42154"},"products":["magento-lts"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["OpenMage"]},"summary":"Attackers can hijack active API sessions by brute-forcing predictable MD5-based session IDs generated from time-derived inputs.","url":"https://insights.sbomify.com/CVE-2026-42155/"}