{"answers":{"affected":"2 open source packages ship an affected version, including lemmy_api_common.","exploited":"There is no known exploitation of CVE-2026-42180 in the wild and no public exploit code.","fix":"Upgrade lemmy_api_common to 0.19.18 or later.","what":"CVE-2026-42180 is a medium-severity server-side request forgery vulnerability in LemmyNet lemmy, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42180 and fix it if it is affected.\n\nWhat it is: CVE-2026-42180 is a medium-severity server-side request forgery vulnerability in LemmyNet lemmy, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42180 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lemmy_api_common (crates.io): affected all versions; fixed in 0.19.18\n- lemmy_api_common (crates.io): affected all versions; fixed in 0.19.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42180/ (Markdown: https://insights.sbomify.com/CVE-2026-42180/index.md)","id":"CVE-2026-42180","markdown":"https://insights.sbomify.com/CVE-2026-42180/index.md","name":"CVE-2026-42180","record":{"aliases":["GHSA-3jvj-v6w2-h948"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Fediverse link aggregator","requires_auth":"low_privilege","summary":"Authenticated users can trigger server-side requests to internal services via Webmention dispatch in Lemmy, potentially exposing internal data.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Lemmy is a link aggregator and forum for the fediverse. Prior to version 0.19.18, Lemmy allows an authenticated low-privileged user to create a link post through POST /api/v3/post. When a post is created in a public community, the backend asynchronously sends a Webmention to the attacker-controlled link target. The submitted URL is checked for syntax and scheme, but the audited code path does not reject loopback, private, or link-local destinations before the Webmention request is issued. This lets a normal user trigger server-side HTTP requests toward internal services. This issue has been patched in version 0.19.18.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Lemmy: SSRF in /api/v3/post via Webmention dispatch","id":"CVE-2026-42180","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Lemmy: SSRF and internal image disclosure in post link metadata via unvalidated og:image","id":"CVE-2026-42181"},"packages":[{"ecosystem":"crates.io","fixed":["0.19.18"],"introduced":["0"],"last_affected":[],"package":"lemmy_api_common","purl":null,"source":"GHSA-3jvj-v6w2-h948"},{"ecosystem":"crates.io","fixed":["0.19.18"],"introduced":["0"],"last_affected":[],"package":"lemmy_api_common","purl":"pkg:cargo/lemmy_api_common","source":"GHSA-3jvj-v6w2-h948"}],"prev":{"headline":"linux-entra-sso: PRT SSO cookie can leak to attacker-controlled hosts when broad host permissions are granted","id":"CVE-2026-42177"},"products":["lemmy"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-13","vendors":["LemmyNet"]},"summary":"Authenticated users can trigger server-side requests to internal services via Webmention dispatch in Lemmy, potentially exposing internal data.","url":"https://insights.sbomify.com/CVE-2026-42180/"}