# CVE-2026-42181: Lemmy: SSRF and internal image disclosure in post link metadata via unvalidated og:image

> An authenticated user can trigger server-side requests to internal endpoints via unvalidated Open Graph image URLs, exposing internal data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-h6hf-9846-xwrq

## What is CVE-2026-42181?

CVE-2026-42181 is a medium-severity server-side request forgery vulnerability in LemmyNet lemmy, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lemmy is a link aggregator and forum for the fediverse. Prior to version 0.19.18, Lemmy fetches metadata for user-supplied post URLs and, under the default StoreLinkPreviews image mode, downloads the preview image through local pict-rs. While the top-level page URL is checked against internal IP ranges, the extracted og:image URL is not subject to the same restriction. As a result, an authenticated low-privileged user can submit an attacker-controlled public page whose Open Graph image points to an internal image endpoint. Lemmy will fetch that internal image server-side and store a local thumbnail that can then be served back to users. This issue has been patched in version 0.19.18.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-42181?

2 open source packages ship an affected version, including lemmy_api_common.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemmy_api_common` | crates.io | All versions | 0.19.18 |
| `lemmy_api_common` | crates.io | All versions | 0.19.18 |

## How do I fix CVE-2026-42181?

Upgrade lemmy_api_common to 0.19.18 or later.

## Is CVE-2026-42181 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42181 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42181 and fix it if it is affected.

What it is: CVE-2026-42181 is a medium-severity server-side request forgery vulnerability in LemmyNet lemmy, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42181 exists.

Affected packages and fixed versions:
- lemmy_api_common (crates.io): affected all versions; fixed in 0.19.18
- lemmy_api_common (crates.io): affected all versions; fixed in 0.19.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42181/ (Markdown: https://insights.sbomify.com/CVE-2026-42181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42181
- OSV: https://osv.dev/vulnerability/CVE-2026-42181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42181/
Summaries are generated and may contain mistakes; the official description above is the record.
