# CVE-2026-42184: Tauri: Origin Confusion Allows Remote Pages to Invoke Local-Only IPC Commands

> Attackers can invoke local-only IPC commands by hosting pages on matching subdomains, potentially leading to code execution or security bypass in Tauri apps.

- **Severity:** Medium 6.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-7gmj-67g7-phm9

## What is CVE-2026-42184?

CVE-2026-42184 is a medium-severity server-side request forgery vulnerability in tauri-apps tauri, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Tauri is a framework for building binaries for all major desktop platforms. From 2.0 to 2.11.0, a flaw in Tauri's is_local_url() function causes it to incorrectly classify remote URLs as trusted local origins on Windows and Android. On these systems, Tauri maps custom URI scheme protocols to http://<scheme>.localhost/ because those platforms' WebView implementations cannot serve custom URI schemes directly. The issue is that Tauri's check to see if the origin is local, only checks the first subdomain of the URL. An attacker can abuse this by hosting a page on a domain whose subdomain matches the custom scheme of the application. This vulnerability is fixed in 2.10.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-42184?

2 open source packages ship an affected version, including tauri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tauri` | crates.io | From 2.0.0 | 2.11.1 |
| `tauri` | crates.io | From 2.0.0 | 2.11.1 |

Products: Tauri Tauri.

## How do I fix CVE-2026-42184?

Upgrade tauri to 2.11.1 or later.

## Is CVE-2026-42184 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42184 exists.

## Other vulnerabilities in tauri-apps tauri

- [CVE-2023-46115](https://insights.sbomify.com/CVE-2023-46115/): Updater Private Keys Possibly Leaked via Vite Environment Variables in tauri-cli (high 8.4)
- [CVE-2022-39215](https://insights.sbomify.com/CVE-2022-39215/): The readDir Endpoint Scope can be Bypassed With Symbolic Links in Tauri (high 8.3)
- [CVE-2022-46171](https://insights.sbomify.com/CVE-2022-46171/): Tauri vulnerable to path traversal (medium 6.8)
- [CVE-2023-34460](https://insights.sbomify.com/CVE-2023-34460/): Tauri vulnerable to Regression on Filesystem Scope Checks for Dotfiles (medium 4.8)
- [CVE-2023-31134](https://insights.sbomify.com/CVE-2023-31134/): Tauri Open Redirect Vulnerability Possibly Exposes IPC to External Sites (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42184 and fix it if it is affected.

What it is: CVE-2026-42184 is a medium-severity server-side request forgery vulnerability in tauri-apps tauri, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42184 exists.

Affected packages and fixed versions:
- tauri (crates.io): affected from 2.0.0; fixed in 2.11.1
- tauri (crates.io): affected from 2.0.0; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42184/ (Markdown: https://insights.sbomify.com/CVE-2026-42184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42184
- OSV: https://osv.dev/vulnerability/CVE-2026-42184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42184/
Summaries are generated and may contain mistakes; the official description above is the record.
