# CVE-2026-42186: OpenBao's Namespace Deletion May Not Delete Data Properly

> Incomplete namespace deletion in OpenBao may leave residual data and active leases, potentially exposing sensitive information or causing state inconsistencies.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** BIT-openbao-2026-42186, GHSA-vv66-6rp4-wr4f, GO-2026-5674

## What is CVE-2026-42186?

CVE-2026-42186 is a low-severity vulnerability in openbao, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to 2.5.3, when OpenBao's initial namespace deletion fails, subsequent retries fail to properly remove all data before marking the namespace as deleted. This can affect any outstanding leases as well as potentially leaving unrelated storage entries around. This vulnerability is fixed in 2.5.3.

Weakness: CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer)

## Which versions are affected by CVE-2026-42186?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420173541-6d2e0506e2b4 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420173541-6d2e0506e2b4 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420173541-6d2e0506e2b4 |
| `openbao` | Bitnami | All versions | 2.5.3 |

Products: Openbao Openbao.

## How do I fix CVE-2026-42186?

Upgrade github.com/openbao/openbao to 0.0.0-20260420173541-6d2e0506e2b4 or later.

## Is CVE-2026-42186 being exploited?

There is no known exploitation of CVE-2026-42186 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42186 and fix it if it is affected.

What it is: CVE-2026-42186 is a low-severity vulnerability in openbao, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42186 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420173541-6d2e0506e2b4
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420173541-6d2e0506e2b4
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420173541-6d2e0506e2b4
- openbao (Bitnami): affected all versions; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42186/ (Markdown: https://insights.sbomify.com/CVE-2026-42186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42186
- OSV: https://osv.dev/vulnerability/CVE-2026-42186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42186/
Summaries are generated and may contain mistakes; the official description above is the record.
