# CVE-2026-42192: Plunk: Stored XSS in campaign view

> Authenticated users can inject malicious scripts into email campaigns that execute in admin browsers, enabling session hijacking and unauthorized actions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-mjqc-qrv3-24hq

## What is CVE-2026-42192?

CVE-2026-42192 is a medium-severity cross-site scripting vulnerability in useplunk plunk, published on 8 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Plunk is an open-source email platform built on top of AWS SES. Prior to version 0.9.0, a stored cross-site scripting (XSS) vulnerability exists in the campaign management feature, where the email body content created by authenticated project members is stored and later rendered in the admin dashboard using React's dangerouslySetInnerHTML without any HTML sanitization. This allows a lower-privileged member to embed malicious scripts in a campaign's email body that execute in the context of any admin or other member who views the campaign, potentially enabling session hijacking or unauthorized actions on their behalf. This issue has been patched in version 0.9.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42192?


## How do I fix CVE-2026-42192?

No fix has been published for CVE-2026-42192 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42192 being exploited?

There is no known exploitation of CVE-2026-42192 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42192 and fix it if it is affected.

What it is: CVE-2026-42192 is a medium-severity cross-site scripting vulnerability in useplunk plunk, published on 8 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42192 in the wild and no public exploit code.

Affected product: useplunk plunk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42192/ (Markdown: https://insights.sbomify.com/CVE-2026-42192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42192
- OSV: https://osv.dev/vulnerability/CVE-2026-42192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42192/
Summaries are generated and may contain mistakes; the official description above is the record.
