CVE-2026-42199 Grid: Integer Overflow in Grid::expand_rows Leads to Safe-API Undefined Behavior

Medium 6.2 Published Updated

An integer overflow in the Rust grid library allows attackers to trigger undefined behavior via safe API calls, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42199?

CVE-2026-42199 is a medium-severity vulnerability in becheran grid, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Grid is a data structure grid for rust. From version 0.17.0 to before version 1.0.1, an integer overflow in Grid::expand_rows() can corrupt the relationship between the grid’s logical dimensions and its backing storage. After the internal invariant is broken, the safe API get() may invoke get_unchecked() with an invalid index, resulting in Undefined Behavior. This issue has been patched in version 1.0.1.

Weakness: CWE-190

Which versions are affected by CVE-2026-42199?

2 open source packages ship an affected version, including grid.

PackageAffectedFixed in
grid crates.ioFrom 0.17.01.0.1
grid crates.ioFrom 0.17.01.0.1

How do I fix CVE-2026-42199?

Upgrade grid to 1.0.1 or later.

Is CVE-2026-42199 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42199 exists.

Sources

Also known as GHSA-38c5-483c-4qqp.

Is CVE-2026-42199 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free