# CVE-2026-42199: Grid: Integer Overflow in Grid::expand_rows Leads to Safe-API Undefined Behavior

> An integer overflow in the Rust grid library allows attackers to trigger undefined behavior via safe API calls, potentially leading to code execution.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-38c5-483c-4qqp

## What is CVE-2026-42199?

CVE-2026-42199 is a medium-severity vulnerability in becheran grid, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Grid is a data structure grid for rust. From version 0.17.0 to before version 1.0.1, an integer overflow in Grid::expand_rows() can corrupt the relationship between the grid’s logical dimensions and its backing storage. After the internal invariant is broken, the safe API get() may invoke get_unchecked() with an invalid index, resulting in Undefined Behavior. This issue has been patched in version 1.0.1.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-42199?

2 open source packages ship an affected version, including grid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grid` | crates.io | From 0.17.0 | 1.0.1 |
| `grid` | crates.io | From 0.17.0 | 1.0.1 |

## How do I fix CVE-2026-42199?

Upgrade grid to 1.0.1 or later.

## Is CVE-2026-42199 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42199 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42199 and fix it if it is affected.

What it is: CVE-2026-42199 is a medium-severity vulnerability in becheran grid, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42199 exists.

Affected packages and fixed versions:
- grid (crates.io): affected from 0.17.0; fixed in 1.0.1
- grid (crates.io): affected from 0.17.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42199/ (Markdown: https://insights.sbomify.com/CVE-2026-42199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42199
- OSV: https://osv.dev/vulnerability/CVE-2026-42199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42199/
Summaries are generated and may contain mistakes; the official description above is the record.
