{"answers":{"affected":"3 open source packages ship an affected version, including litellm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-42203 in the wild and no public exploit code.","fix":"Upgrade litellm to 1.83.7 or later.","what":"CVE-2026-42203 is a high-severity code injection vulnerability in BerriAI litellm, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42203 and fix it if it is affected.\n\nWhat it is: CVE-2026-42203 is a high-severity code injection vulnerability in BerriAI litellm, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42203 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected from 1.80.5; fixed in 1.83.7\n- litellm (PyPI): affected from 1.80.5; fixed in 1.83.7\n- litellm (PyPI): affected from 1.80.5; fixed in 1.83.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42203/ (Markdown: https://insights.sbomify.com/CVE-2026-42203/index.md)","id":"CVE-2026-42203","markdown":"https://insights.sbomify.com/CVE-2026-42203/index.md","name":"CVE-2026-42203","record":{"aliases":["CLEANSTART-2026-OY83568","ECHO-cec0-f797-4e78","GHSA-xqmj-j6mv-4862","MINI-6rvq-x8xq-rm8p","MINI-f939-hjqj-rhv7","MINI-ggq5-3hr9-pxr8","MINI-jhhm-9qvq-vxjg","MINI-rfxq-xxm7-g6vr","MINI-vg9f-g8j6-r7r6","PYSEC-2026-2602"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AI Gateway Proxy","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary code via Server-Side Template Injection in the LiteLLM proxy, potentially exposing secrets and compromising the host.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"litellm","vendor":"litellm"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.80.5 to before version 1.83.7, the POST /prompts/test endpoint accepted user-supplied prompt templates and rendered them without sandboxing. A crafted template could run arbitrary code inside the LiteLLM Proxy process. The endpoint only checks that the caller presents a valid proxy API key, so any authenticated user could reach it. Depending on how the proxy is deployed, this could expose secrets in the process environment (such as provider API keys or database credentials) and allow commands to be run on the host. This issue has been patched in version 1.83.7.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-05-15","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-15T15:49:40Z","kind":"github_poc","ref":"https://github.com/Astianjy/CVE-2026-42203","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"LiteLLM: Server-Side Template Injection in /prompts/test endpoint","id":"CVE-2026-42203","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Coolify: Authenticated RCE via SHELL_SAFE_COMMAND_PATTERN regression → host root","id":"CVE-2026-42204"},"packages":[{"ecosystem":"PyPI","fixed":["1.83.7"],"introduced":["1.80.5"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-xqmj-j6mv-4862"},{"ecosystem":"PyPI","fixed":["1.83.7"],"introduced":["1.80.5"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-xqmj-j6mv-4862"},{"ecosystem":"PyPI","fixed":["1.83.7"],"introduced":["1.80.5"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-2602"}],"prev":{"headline":"nova-toggle-5: Improper authorization on toggle endpoint allowed non-Nova users to modify boolean fields","id":"CVE-2026-42202"},"products":["litellm"],"published":"2026-05-08","related":[{"cvss_score":9.3,"headline":"BerriAI LiteLLM SQL Injection","id":"CVE-2026-42208","kev_date_added":"2026-05-08","published":"2026-05-08"},{"cvss_score":8.8,"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822","kev_date_added":"2026-09-02","published":"2026-07-08"},{"cvss_score":8.7,"headline":"BerriAI LiteLLM Command Injection","id":"CVE-2026-42271","kev_date_added":"2026-06-08","published":"2026-05-08"},{"cvss_score":9.8,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-5751","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":9.8,"headline":"Server-Side Template Injection in BerriAI/litellm","id":"CVE-2024-2952","kev_date_added":null,"published":"2024-04-10"},{"cvss_score":9.5,"headline":"LiteLLM: Authentication Bypass via Host Header Injection","id":"CVE-2026-49468","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.4,"headline":"LiteLLM has an authentication bypass via OIDC userinfo cache key collision","id":"CVE-2026-35030","kev_date_added":null,"published":"2026-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["BerriAI"]},"summary":"Authenticated users can execute arbitrary code via Server-Side Template Injection in the LiteLLM proxy, potentially exposing secrets and compromising the host.","url":"https://insights.sbomify.com/CVE-2026-42203/"}