# CVE-2026-42203: LiteLLM: Server-Side Template Injection in /prompts/test endpoint

> Authenticated users can execute arbitrary code via Server-Side Template Injection in the LiteLLM proxy, potentially exposing secrets and compromising the host.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-OY83568, ECHO-cec0-f797-4e78, GHSA-xqmj-j6mv-4862, MINI-6rvq-x8xq-rm8p, MINI-f939-hjqj-rhv7, MINI-ggq5-3hr9-pxr8, MINI-jhhm-9qvq-vxjg, MINI-rfxq-xxm7-g6vr, MINI-vg9f-g8j6-r7r6, PYSEC-2026-2602

## What is CVE-2026-42203?

CVE-2026-42203 is a high-severity code injection vulnerability in BerriAI litellm, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.80.5 to before version 1.83.7, the POST /prompts/test endpoint accepted user-supplied prompt templates and rendered them without sandboxing. A crafted template could run arbitrary code inside the LiteLLM Proxy process. The endpoint only checks that the caller presents a valid proxy API key, so any authenticated user could reach it. Depending on how the proxy is deployed, this could expose secrets in the process environment (such as provider API keys or database credentials) and allow commands to be run on the host. This issue has been patched in version 1.83.7.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-42203?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | From 1.80.5 | 1.83.7 |
| `litellm` | PyPI | From 1.80.5 | 1.83.7 |
| `litellm` | PyPI | From 1.80.5 | 1.83.7 |

Products: Litellm Litellm.

## How do I fix CVE-2026-42203?

Upgrade litellm to 1.83.7 or later.

## Is CVE-2026-42203 being exploited?

There is no known exploitation of CVE-2026-42203 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Astianjy/CVE-2026-42203 (github_poc): https://github.com/Astianjy/CVE-2026-42203

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42203 and fix it if it is affected.

What it is: CVE-2026-42203 is a high-severity code injection vulnerability in BerriAI litellm, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42203 in the wild and no public exploit code.

Affected packages and fixed versions:
- litellm (PyPI): affected from 1.80.5; fixed in 1.83.7
- litellm (PyPI): affected from 1.80.5; fixed in 1.83.7
- litellm (PyPI): affected from 1.80.5; fixed in 1.83.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42203/ (Markdown: https://insights.sbomify.com/CVE-2026-42203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42203
- OSV: https://osv.dev/vulnerability/CVE-2026-42203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42203/
Summaries are generated and may contain mistakes; the official description above is the record.
