{"answers":{"affected":"2 open source packages ship an affected version, including avo.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42205 exists.","fix":"Upgrade avo to 3.31.2 or later.","what":"CVE-2026-42205 is a high-severity missing authorization vulnerability in avo-hq avo, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42205 and fix it if it is affected.\n\nWhat it is: CVE-2026-42205 is a high-severity missing authorization vulnerability in avo-hq avo, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42205 exists.\n\nAffected packages and fixed versions:\n- avo (RubyGems): affected all versions; fixed in 3.31.2\n- avo (RubyGems): affected all versions; fixed in 3.31.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42205/ (Markdown: https://insights.sbomify.com/CVE-2026-42205/index.md)","id":"CVE-2026-42205","markdown":"https://insights.sbomify.com/CVE-2026-42205/index.md","name":"CVE-2026-42205","record":{"aliases":["GHSA-qc5p-3mg5-9fh8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails admin framework","requires_auth":"low_privilege","summary":"Authenticated users can execute unauthorized actions on any resource due to broken access control, leading to privilege escalation and data manipulation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"Avo is a framework to create admin panels for Ruby on Rails apps. Prior to version 3.31.2, a broken access control vulnerability was identified in the ActionsController of the Avo framework. Due to insecure action lookup logic, an authenticated user can execute any Action class (descendants of Avo::BaseAction) on any resource, even if the action is not registered for that specific resource. This leads to Privilege Escalation and unauthorized data manipulation across the entire application. This issue has been patched in version 3.31.2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Avo: Broken Access Control: Unauthorized Execution of Arbitrary Action Classes Across Resources","id":"CVE-2026-42205","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Roadiz OpenID Connect nonce generated but never validated — ID token replay attack","id":"CVE-2026-42206"},"packages":[{"ecosystem":"RubyGems","fixed":["3.31.2"],"introduced":["0"],"last_affected":[],"package":"avo","purl":null,"source":"GHSA-qc5p-3mg5-9fh8"},{"ecosystem":"RubyGems","fixed":["3.31.2"],"introduced":["0"],"last_affected":[],"package":"avo","purl":"pkg:gem/avo","source":"GHSA-qc5p-3mg5-9fh8"}],"prev":{"headline":"Coolify: Authenticated RCE via SHELL_SAFE_COMMAND_PATTERN regression → host root","id":"CVE-2026-42204"},"products":["avo"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-12","vendors":["avo-hq"]},"summary":"Authenticated users can execute unauthorized actions on any resource due to broken access control, leading to privilege escalation and data manipulation.","url":"https://insights.sbomify.com/CVE-2026-42205/"}