# CVE-2026-42205: Avo: Broken Access Control: Unauthorized Execution of Arbitrary Action Classes Across Resources

> Authenticated users can execute unauthorized actions on any resource due to broken access control, leading to privilege escalation and data manipulation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-qc5p-3mg5-9fh8

## What is CVE-2026-42205?

CVE-2026-42205 is a high-severity missing authorization vulnerability in avo-hq avo, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Avo is a framework to create admin panels for Ruby on Rails apps. Prior to version 3.31.2, a broken access control vulnerability was identified in the ActionsController of the Avo framework. Due to insecure action lookup logic, an authenticated user can execute any Action class (descendants of Avo::BaseAction) on any resource, even if the action is not registered for that specific resource. This leads to Privilege Escalation and unauthorized data manipulation across the entire application. This issue has been patched in version 3.31.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-42205?

2 open source packages ship an affected version, including avo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `avo` | RubyGems | All versions | 3.31.2 |
| `avo` | RubyGems | All versions | 3.31.2 |

## How do I fix CVE-2026-42205?

Upgrade avo to 3.31.2 or later.

## Is CVE-2026-42205 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42205 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42205 and fix it if it is affected.

What it is: CVE-2026-42205 is a high-severity missing authorization vulnerability in avo-hq avo, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42205 exists.

Affected packages and fixed versions:
- avo (RubyGems): affected all versions; fixed in 3.31.2
- avo (RubyGems): affected all versions; fixed in 3.31.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42205/ (Markdown: https://insights.sbomify.com/CVE-2026-42205/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42205
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42205
- OSV: https://osv.dev/vulnerability/CVE-2026-42205

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42205/
Summaries are generated and may contain mistakes; the official description above is the record.
