# CVE-2026-42207: Magento LTS: Open Redirect via Unvalidated `uenc` Parameter in `stockAction()` - magento-lts


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-qpgq-5g92-j5q8

## What is CVE-2026-42207?

CVE-2026-42207 is a medium-severity vulnerability in OpenMage magento-lts, published on 15 May 2026. 

### Official description

Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, Mage_ProductAlert_AddController::stockAction() reads the uenc query parameter and passes it directly to $this->_redirectUrl($backUrl) without calling $this->_isUrlInternal(). When the supplied product_id does not match any catalog product, the server issues an unvalidated HTTP 302 redirect to whatever URL was provided as uenc. This vulnerability is fixed in 20.18.0.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-42207?

2 open source packages ship an affected version, including openmage/magento-lts.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 20.18.0 |
| `openmage/magento-lts` | Packagist | All versions | 20.18.0 |

## How do I fix CVE-2026-42207?

Upgrade openmage/magento-lts to 20.18.0 or later.

## Is CVE-2026-42207 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42207 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42207 and fix it if it is affected.

What it is: CVE-2026-42207 is a medium-severity vulnerability in OpenMage magento-lts, published on 15 May 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42207 exists.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.18.0
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42207/ (Markdown: https://insights.sbomify.com/CVE-2026-42207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42207
- OSV: https://osv.dev/vulnerability/CVE-2026-42207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42207/
Summaries are generated and may contain mistakes; the official description above is the record.
