# CVE-2026-42208: BerriAI LiteLLM SQL Injection

> Unauthenticated attackers can exploit SQL injection in LiteLLM proxy API key verification to read and modify database contents, potentially compromising managed credentials.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Yes, since 8 May 2026 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-r75f-5x8p-qvmc, MINI-5vrj-xm9r-fw8v, MINI-8mpq-7g6h-p423, MINI-c97q-f268-2m9f, MINI-jpp6-g7fg-cp46, PYSEC-2026-391

## What is CVE-2026-42208?

CVE-2026-42208 is a critical SQL injection vulnerability in BerriAI litellm, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-42208?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | From 1.81.16 | 1.83.7 |
| `litellm` | PyPI | From 1.81.16 | 1.83.7 |
| `litellm` | PyPI | From 1.81.16 | 1.83.7 |

Products: Litellm Litellm.

## How do I fix CVE-2026-42208?

Upgrade litellm to 1.83.7 or later. US federal agencies must fix it by 11 May 2026.

## Is CVE-2026-42208 being exploited?

Yes. Attackers have exploited CVE-2026-42208 in the wild since at least 8 May 2026.

Public exploit code:

- Scanner: CVE-2026-42208 LiteLLM SQL Injection — Python scanner for BerriAI LiteLLM proxy instances (github_poc): https://github.com/ridhinva/litellm-sqli-scanner
- BerriAI LiteLLM Proxy Pre-Auth SQL Injection Scanner (metasploit)
- CVE-2026-42208 lab (github_poc): https://github.com/imjdl/CVE-2026-42208_lab
- CVE-2026-40487 (github_poc): https://github.com/0xredash/CVE-2026-42208
- Threat intelligence brief on CVE-2026-42208, a critical pre-auth SQL injection in BerriAI LiteLLM exploited within 36 hours of disclosure. Covers attack path, detection opportunities, and recommended actions. (github_poc): https://github.com/Zeltoc/threat-intel-brief-cve-2026-42208-litellm
- https://github.com/rootdirective-sec/CVE-2026-42208-Lab (github_poc): https://github.com/rootdirective-sec/CVE-2026-42208-Lab

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)
- [CVE-2026-49468](https://insights.sbomify.com/CVE-2026-49468/): LiteLLM: Authentication Bypass via Host Header Injection (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42208 and fix it if it is affected.

What it is: CVE-2026-42208 is a critical SQL injection vulnerability in BerriAI litellm, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2026-42208 in the wild since at least 8 May 2026.

Affected packages and fixed versions:
- litellm (PyPI): affected from 1.81.16; fixed in 1.83.7
- litellm (PyPI): affected from 1.81.16; fixed in 1.83.7
- litellm (PyPI): affected from 1.81.16; fixed in 1.83.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42208/ (Markdown: https://insights.sbomify.com/CVE-2026-42208/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42208
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42208
- OSV: https://osv.dev/vulnerability/CVE-2026-42208

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42208/
Summaries are generated and may contain mistakes; the official description above is the record.
