# CVE-2026-42211: React Router's vendored turbo-stream v2 allows arbitrary constructor invocation via TYPE_ERROR deserialization leading to Unauth RCE

> Attackers can achieve remote code execution in React Router Framework Mode via unsafe deserialization if prototype pollution exists.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** CLSA-2026-1784856365, CLSA-2026-1792192812, CLSA-2026-1792253397, CLSA-2026-1792253409, CLSA-2026-1792419112, CLSA-2026-1792419189, CLSA-2026-1792419268, CLSA-2026-1792419624, CLSA-2026-1792421942, CLSA-2026-1792424731, CLSA-2026-1792425406, CLSA-2026-1792428106, CLSA-2026-1792430031, GHSA-49rj-9fvp-4h2h, ROOT-APP-NPM-CVE-2026-42211

## What is CVE-2026-42211?

CVE-2026-42211 is a high-severity unsafe deserialization vulnerability in remix-run react-router, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

React Router is a router for React. In versions 7.0.0 through 7.14.1, when using Framework Mode, a combination of steps could potentially allow unauthorized remote code execution (RCE) through external requests. This attack requires the application code to have an existing prototype pollution vulnerability, which can then be leveraged in a 2-step attack where the second step triggers unauthorized RCE on the remote server. This does not impact applications using Declarative Mode (`<BrowserRouter>`) or Data Mode (`createBrowserRouter/<RouterProvider>`). This is patched in version 7.14.2.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-42211?

2 open source packages ship an affected version, including react-router. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-router` | npm | From 7.0.0 | 7.14.2 |
| `react-router` | npm | From 7.0.0 | 7.14.2 |

Products: Shopify React-Router.

## How do I fix CVE-2026-42211?

Upgrade react-router to 7.14.2 or later.

## Is CVE-2026-42211 being exploited?

There is no known exploitation of CVE-2026-42211 in the wild and no public exploit code.

## Other vulnerabilities in remix-run react-router

- [CVE-2026-55685](https://insights.sbomify.com/CVE-2026-55685/): React Router: Unauthenticated Denial of Service via Inefficient Route Matching (high 8.7)
- [CVE-2026-21884](https://insights.sbomify.com/CVE-2026-21884/): React Router SSR XSS in ScrollRestoration (high 8.2)
- [CVE-2026-33245](https://insights.sbomify.com/CVE-2026-33245/): React Router vulnerable to XSS in unstable RSC redirect handling via javascript: redirect targets (high 8.0)
- [CVE-2026-22029](https://insights.sbomify.com/CVE-2026-22029/): React Router vulnerable to XSS via Open Redirects (high 8.0)
- [CVE-2025-59057](https://insights.sbomify.com/CVE-2025-59057/): React Router has XSS Vulnerability (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42211 and fix it if it is affected.

What it is: CVE-2026-42211 is a high-severity unsafe deserialization vulnerability in remix-run react-router, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42211 in the wild and no public exploit code.

Affected packages and fixed versions:
- react-router (npm): affected from 7.0.0; fixed in 7.14.2
- react-router (npm): affected from 7.0.0; fixed in 7.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42211/ (Markdown: https://insights.sbomify.com/CVE-2026-42211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42211
- OSV: https://osv.dev/vulnerability/CVE-2026-42211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42211/
Summaries are generated and may contain mistakes; the official description above is the record.
