# CVE-2026-42212: SolidCAM-GPPL-IDE: XML External Entity (XXE) and billion-laughs DoS in VMID parser

> Attackers can disclose local files and cause denial of service via malicious VMID files in SolidCAM Postprocessor IDE due to unsafe XML parsing.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-92vg-f4fq-fxm9

## What is CVE-2026-42212?

CVE-2026-42212 is a high-severity vulnerability in anzory SolidCAM-GPPL-IDE, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SolidCAM-GPPL-IDE is an unofficial, independently developed extension, Postprocessor IDE for SolidCAM. From version 1.0.0 to before version 1.0.2, Opening a .gpp file in the SolidCAM Postprocessor IDE extension causes the language server to parse a companion .vmid file from the same directory (naming convention: foo.gpp to foo.vmid). The VMID parser called XDocument.Load(path) without any XmlReaderSettings, inheriting the framework defaults which in .NET 8 allow DTD processing. A malicious .vmid file could therefore: disclose local files via external entity references, exhaust memory via recursive entity expansion, and cause denial of service via oversized or deeply nested XML. This issue has been patched in version 1.0.2.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs), CWE-611 (Improper Restriction of XML External Entity Reference), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-42212?


## How do I fix CVE-2026-42212?

No fix has been published for CVE-2026-42212 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42212 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42212 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42212 and fix it if it is affected.

What it is: CVE-2026-42212 is a high-severity vulnerability in anzory SolidCAM-GPPL-IDE, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42212 exists.

Affected product: anzory SolidCAM-GPPL-IDE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42212/ (Markdown: https://insights.sbomify.com/CVE-2026-42212/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42212
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42212
- OSV: https://osv.dev/vulnerability/CVE-2026-42212

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42212/
Summaries are generated and may contain mistakes; the official description above is the record.
