# CVE-2026-42213: SolidCAM-GPPL-IDE: Path traversal in `inc` directive enables file probing and NTLM-hash leak

> Attackers can exploit path traversal in the inc directive to probe file existence and leak NTLM hashes via UNC paths in the SolidCAM-GPPL-IDE extension.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-xvpx-9p39-g62m

## What is CVE-2026-42213?

CVE-2026-42213 is a medium-severity path traversal vulnerability in anzory SolidCAM-GPPL-IDE, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SolidCAM-GPPL-IDE is an unofficial, independently developed extension, Postprocessor IDE for SolidCAM. From version 1.0.0 to before version 1.0.2, the inc "filename" directive in GPPL postprocessor files is resolved by GpplDocumentLinkHandler into a clickable link (VS Code textDocument/documentLink). The handler accepted arbitrary paths — absolute, relative with parent-directory segments (..\..\..\), UNC (\\server\share\), and arbitrary subfolders — and called File.Exists on each to decide whether to render the link. Two distinct attack surfaces resulted: information disclosure via File.Exists probing and NTLM hash leak via UNC path probing. This issue has been patched in version 1.0.2.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-295 (Improper Certificate Validation), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-42213?


## How do I fix CVE-2026-42213?

No fix has been published for CVE-2026-42213 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42213 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42213 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42213 and fix it if it is affected.

What it is: CVE-2026-42213 is a medium-severity path traversal vulnerability in anzory SolidCAM-GPPL-IDE, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42213 exists.

Affected product: anzory SolidCAM-GPPL-IDE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42213/ (Markdown: https://insights.sbomify.com/CVE-2026-42213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42213
- OSV: https://osv.dev/vulnerability/CVE-2026-42213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42213/
Summaries are generated and may contain mistakes; the official description above is the record.
