{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42214 exists.","fix":"No fix has been published for CVE-2026-42214 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-42214 is a high-severity code injection vulnerability in dail8859 NotepadNext, published on 7 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42214 and fix it if it is affected.\n\nWhat it is: CVE-2026-42214 is a high-severity code injection vulnerability in dail8859 NotepadNext, published on 7 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42214 exists.\n\nAffected product: dail8859 NotepadNext. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42214/ (Markdown: https://insights.sbomify.com/CVE-2026-42214/index.md)","id":"CVE-2026-42214","markdown":"https://insights.sbomify.com/CVE-2026-42214/index.md","name":"CVE-2026-42214","record":{"aliases":["GHSA-m5fq-c9x5-w54g"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Notepad Next editor","requires_auth":"none","summary":"Attackers can execute arbitrary code by crafting filenames with malicious Lua extensions, affecting users of Notepad Next.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"notepad_next","vendor":"dail8859"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Notepad Next is a cross-platform, reimplementation of Notepad++. Prior to version 0.14, NotepadNext's detectLanguageFromExtension() function interpolates a file's extension directly into a Lua script without sanitization. An attacker can craft a filename whose extension contains Lua code, which executes automatically when the victim opens the file in NotepadNext. Because luaL_openlibs() is called unconditionally, the full os, io, and package libraries are available to the injected code, enabling arbitrary command execution. This issue has been patched in version 0.14.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Improper Control of Generation of Code ('Code Injection') in dail8859/NotepadNext","id":"CVE-2026-42214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"GitPython: Command injection via Git options bypass","id":"CVE-2026-42215"},"packages":[],"prev":{"headline":"SolidCAM-GPPL-IDE: Path traversal in `inc` directive enables file probing and NTLM-hash leak","id":"CVE-2026-42213"},"products":["NotepadNext"],"published":"2026-05-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-09","vendors":["dail8859"]},"summary":"Attackers can execute arbitrary code by crafting filenames with malicious Lua extensions, affecting users of Notepad Next.","url":"https://insights.sbomify.com/CVE-2026-42214/"}