# CVE-2026-42215: GitPython: Command injection via Git options bypass

> Attackers can execute arbitrary commands by bypassing Git option restrictions in GitPython when passing controlled kwargs to clone or fetch methods.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 9 May 2026
- **Also known as:** DEBIAN-CVE-2026-42215, ECHO-4767-0efd-0b25, GHSA-rpm5-65cw-6hj4, MINI-654g-vwgj-h9mv, MINI-cqmx-r7cc-8jwj, PYSEC-2026-2160, ROOT-APP-PYPI-CVE-2026-42215, UBUNTU-CVE-2026-42215

## What is CVE-2026-42215?

CVE-2026-42215 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitPython is a python library used to interact with Git repositories. From version 3.1.30 to before version 3.1.47, GitPython blocks dangerous Git options such as --upload-pack and --receive-pack by default, but the equivalent Python kwargs upload_pack and receive_pack bypass that check. If an application passes attacker-controlled kwargs into Repo.clone_from(), Remote.fetch(), Remote.pull(), or Remote.push(), this leads to arbitrary command execution even when allow_unsafe_options is left at its default value of False. This issue has been patched in version 3.1.47.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-42215?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | From 3.1.30 | 3.1.47 |
| `gitpython` | PyPI | From 3.1.30 | 3.1.47 |
| `GitPython` | PyPI | From 3.1.30 | 3.1.47 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-42215?

Upgrade gitpython to 3.1.47 or later.

## Is CVE-2026-42215 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42215 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)
- [CVE-2026-87819](https://insights.sbomify.com/CVE-2026-87819/): GitPython before 3.1.60 Denial of Service via ReDoS (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42215 and fix it if it is affected.

What it is: CVE-2026-42215 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42215 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected from 3.1.30; fixed in 3.1.47
- gitpython (PyPI): affected from 3.1.30; fixed in 3.1.47
- GitPython (PyPI): affected from 3.1.30; fixed in 3.1.47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42215/ (Markdown: https://insights.sbomify.com/CVE-2026-42215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42215
- OSV: https://osv.dev/vulnerability/CVE-2026-42215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42215/
Summaries are generated and may contain mistakes; the official description above is the record.
