{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42216 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-42216 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42216 and fix it if it is affected.\n\nWhat it is: CVE-2026-42216 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42216 exists.\n\nAffected product: Openexr Openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42216/ (Markdown: https://insights.sbomify.com/CVE-2026-42216/index.md)","id":"CVE-2026-42216","markdown":"https://insights.sbomify.com/CVE-2026-42216/index.md","name":"CVE-2026-42216","record":{"aliases":["BELL-CVE-2026-42216","DEBIAN-CVE-2026-42216","ECHO-7ba5-1829-1400","GHSA-65j8-95g9-jgj4","JLSEC-2026-810","ROOT-OS-DEBIAN-11-CVE-2026-42216","ROOT-OS-DEBIAN-12-CVE-2026-42216","ROOT-OS-DEBIAN-13-CVE-2026-42216","UBUNTU-CVE-2026-42216"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenEXR image library","requires_auth":"none","summary":"An out-of-bounds read in OpenEXR allows attackers to cause denial of service or disclose memory contents via crafted image files.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openexr","vendor":"openexr"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-130","name":"Improper Handling of Length Parameter Inconsistency"},{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From versions 3.0.0 to before 3.2.9, 3.3.0 to before 3.3.11, and 3.4.0 to before 3.4.11, IDManifest::init() reconstructs strings from a prefix-compressed representation. If the previous string is longer than 255 bytes, the next string is expected to begin with a 2-byte prefix length. The code reads stringList[i][0] and stringList[i][1] without checking that the current string has at least two bytes. This issue has been patched in versions 3.2.9, 3.3.11, and 3.4.11.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion","id":"CVE-2026-42216","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"openexr:openexr","products":["openexr:openexr"],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"OpenEXR: Shift exponent overflow in `readVariableLengthInteger()` (`ImfIDManifest.cpp`)","id":"CVE-2026-42217"},"packages":[],"prev":{"headline":"GitPython: Command injection via Git options bypass","id":"CVE-2026-42215"},"products":["openexr"],"published":"2026-05-07","related":[{"cvss_score":9.1,"headline":"OpenEXR Heap Overflow in Scanline Deep Data Parsing","id":"CVE-2023-5841","kev_date_added":null,"published":"2024-02-01"},{"cvss_score":8.8,"headline":"OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API","id":"CVE-2026-41142","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":8.8,"headline":"OpenEXR invalid write","id":"CVE-2017-9111","kev_date_added":null,"published":"2017-05-21"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2017-9113","kev_date_added":null,"published":"2017-05-21"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2017-9115","kev_date_added":null,"published":"2017-05-21"},{"cvss_score":8.7,"headline":"OpenEXR: Heap information disclosure in PXR24 decompression via unchecked decompressed size (undo_pxr24_impl)","id":"CVE-2026-34543","kev_date_added":null,"published":"2026-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-09","vendors":["AcademySoftwareFoundation"]},"summary":"An out-of-bounds read in OpenEXR allows attackers to cause denial of service or disclose memory contents via crafted image files.","url":"https://insights.sbomify.com/CVE-2026-42216/"}