# CVE-2026-42216: OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion

> An out-of-bounds read in OpenEXR allows attackers to cause denial of service or disclose memory contents via crafted image files.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 9 Sep 2026
- **Also known as:** BELL-CVE-2026-42216, DEBIAN-CVE-2026-42216, ECHO-7ba5-1829-1400, GHSA-65j8-95g9-jgj4, JLSEC-2026-810, ROOT-OS-DEBIAN-11-CVE-2026-42216, ROOT-OS-DEBIAN-12-CVE-2026-42216, ROOT-OS-DEBIAN-13-CVE-2026-42216, UBUNTU-CVE-2026-42216

## What is CVE-2026-42216?

CVE-2026-42216 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From versions 3.0.0 to before 3.2.9, 3.3.0 to before 3.3.11, and 3.4.0 to before 3.4.11, IDManifest::init() reconstructs strings from a prefix-compressed representation. If the previous string is longer than 255 bytes, the next string is expected to begin with a 2-byte prefix length. The code reads stringList[i][0] and stringList[i][1] without checking that the current string has at least two bytes. This issue has been patched in versions 3.2.9, 3.3.11, and 3.4.11.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-42216?

It affects 1 product.


Products: Openexr Openexr.

## How do I fix CVE-2026-42216?

Upgrade to a fixed version.

## Is CVE-2026-42216 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42216 exists.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)
- [CVE-2017-9115](https://insights.sbomify.com/CVE-2017-9115/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42216 and fix it if it is affected.

What it is: CVE-2026-42216 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42216 exists.

Affected product: Openexr Openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42216/ (Markdown: https://insights.sbomify.com/CVE-2026-42216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42216
- OSV: https://osv.dev/vulnerability/CVE-2026-42216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42216/
Summaries are generated and may contain mistakes; the official description above is the record.
