# CVE-2026-42217: OpenEXR: Shift exponent overflow in `readVariableLengthInteger()` (`ImfIDManifest.cpp`)

> An attacker can cause a denial of service by providing a crafted EXR file that triggers undefined behavior via an unbounded shift in the OpenEXR library.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** BELL-CVE-2026-42217, DEBIAN-CVE-2026-42217, ECHO-e186-1aab-8c05, GHSA-3c67-4wwp-w52m, JLSEC-2026-811, ROOT-OS-DEBIAN-11-CVE-2026-42217, ROOT-OS-DEBIAN-12-CVE-2026-42217, ROOT-OS-DEBIAN-13-CVE-2026-42217, UBUNTU-CVE-2026-42217

## What is CVE-2026-42217?

CVE-2026-42217 is a medium-severity vulnerability in Openexr Openexr, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From versions 3.0.0 to before 3.2.9, 3.3.0 to before 3.3.11, and 3.4.0 to before 3.4.11, readVariableLengthInteger() decodes a variable-length integer from untrusted EXR input without bounding the shift count. After enough continuation bytes, the code executes a left shift by 70 on a 64-bit value, which is undefined behavior. This issue has been patched in versions 3.2.9, 3.3.11, and 3.4.11.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-42217?

It affects 1 product.


Products: Openexr Openexr.

## How do I fix CVE-2026-42217?

Upgrade to a fixed version.

## Is CVE-2026-42217 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42217 exists.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42217 and fix it if it is affected.

What it is: CVE-2026-42217 is a medium-severity vulnerability in Openexr Openexr, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42217 exists.

Affected product: Openexr Openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42217/ (Markdown: https://insights.sbomify.com/CVE-2026-42217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42217
- OSV: https://osv.dev/vulnerability/CVE-2026-42217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42217/
Summaries are generated and may contain mistakes; the official description above is the record.
