CVE-2026-42221 nginx-ui: Unauthenticated First-Run Installer Allows Remote Initial Admin Claim

High 8.1 Published Updated

Remote attackers can claim the initial admin account on fresh Nginx UI instances via an unauthenticated install endpoint, leading to full system takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42221?

CVE-2026-42221 is a high-severity authentication bypass vulnerability in 0xJacky nginx-ui, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Nginx UI is a web user interface for the Nginx web server. From version 2.0.0 to before version 2.3.8, an unauthenticated network attacker can claim the initial administrator account on a fresh nginx-ui instance during the first-run setup window. The public /api/install endpoint is reachable without authentication, and the request-encryption flow only protects payload confidentiality in transit; it does not authenticate who is allowed to perform installation. A remote attacker who reaches the service before the legitimate operator can set the admin email, username, and password, causing permanent initial-instance takeover. This issue has been patched in version 2.3.8.

Weakness: CWE-306

Which versions are affected by CVE-2026-42221?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI. It affects 1 product.

PackageAffectedFixed in
github.com/0xJacky/Nginx-UI GoAll versionsNone
github.com/0xJacky/Nginx-UI GoFrom 2.0.02.3.8
github.com/0xJacky/Nginx-UI GoFrom 2.0.02.3.8

Products include Nginxui Nginx Ui.

How do I fix CVE-2026-42221?

Upgrade github.com/0xJacky/Nginx-UI to 2.3.8 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-42221 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42221 exists.

Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.

Sources

Also known as GHSA-h27v-ph7w-m9fp, GO-2026-5412.

Is CVE-2026-42221 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free