# CVE-2026-42221: nginx-ui: Unauthenticated First-Run Installer Allows Remote Initial Admin Claim

> Remote attackers can claim the initial admin account on fresh Nginx UI instances via an unauthenticated install endpoint, leading to full system takeover.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 5 May 2026
- **Also known as:** GHSA-h27v-ph7w-m9fp, GO-2026-5412

## What is CVE-2026-42221?

CVE-2026-42221 is a high-severity authentication bypass vulnerability in 0xJacky nginx-ui, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nginx UI is a web user interface for the Nginx web server. From version 2.0.0 to before version 2.3.8, an unauthenticated network attacker can claim the initial administrator account on a fresh nginx-ui instance during the first-run setup window. The public /api/install endpoint is reachable without authentication, and the request-encryption flow only protects payload confidentiality in transit; it does not authenticate who is allowed to perform installation. A remote attacker who reaches the service before the legitimate operator can set the admin email, username, and password, causing permanent initial-instance takeover. This issue has been patched in version 2.3.8.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-42221?

3 open source packages ship an affected version, including github.com/0xJacky/Nginx-UI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/Nginx-UI` | Go | All versions | None |
| `github.com/0xJacky/Nginx-UI` | Go | From 2.0.0 | 2.3.8 |
| `github.com/0xJacky/Nginx-UI` | Go | From 2.0.0 | 2.3.8 |

Products: Nginxui Nginx Ui.

## How do I fix CVE-2026-42221?

Upgrade github.com/0xJacky/Nginx-UI to 2.3.8 or later.

## Is CVE-2026-42221 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42221 exists.

Public exploit code:

- https://github.com/fuchiuebusi-lab/nginx-ui-CVE-2026-42221-CVE-2026-42238- (github_poc): https://github.com/fuchiuebusi-lab/nginx-ui-CVE-2026-42221-CVE-2026-42238-
- Nginx UI <= 2.3.7 - Unauthenticated Installer Exposure (nuclei): http/cves/2026/CVE-2026-42221.yaml

## Other vulnerabilities in 0xJacky nginx-ui

- [CVE-2026-33032](https://insights.sbomify.com/CVE-2026-33032/): Nginx UI: Unauthenticated MCP Endpoint Allows Remote Nginx Takeover (critical 9.8)
- [CVE-2026-27944](https://insights.sbomify.com/CVE-2026-27944/): Nginx UI: Unauthenticated Backup Download with Encryption Key Disclosure (critical 9.8)
- [CVE-2024-23827](https://insights.sbomify.com/CVE-2024-23827/): Nginx-UI arbitrary file write through the Import Certificate feature (critical 9.8)
- [CVE-2026-107806](https://insights.sbomify.com/CVE-2026-107806/): Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite (critical 9.4)
- [CVE-2026-33026](https://insights.sbomify.com/CVE-2026-33026/): nginx-ui Backup Restore Allows Tampering with Encrypted Backups (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42221 and fix it if it is affected.

What it is: CVE-2026-42221 is a high-severity authentication bypass vulnerability in 0xJacky nginx-ui, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42221 exists.

Affected packages and fixed versions:
- github.com/0xJacky/Nginx-UI (Go): affected all versions; no fix listed
- github.com/0xJacky/Nginx-UI (Go): affected from 2.0.0; fixed in 2.3.8
- github.com/0xJacky/Nginx-UI (Go): affected from 2.0.0; fixed in 2.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42221/ (Markdown: https://insights.sbomify.com/CVE-2026-42221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42221
- OSV: https://osv.dev/vulnerability/CVE-2026-42221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42221/
Summaries are generated and may contain mistakes; the official description above is the record.
