# CVE-2026-42223: nginx-ui: Settings API Exposes Protected Secrets

> Authenticated users can retrieve sensitive secrets like JWT and OIDC keys via the Settings API, enabling token forgery and account takeover.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 5 May 2026
- **Also known as:** GHSA-q4w7-56hr-83rm, GO-2026-5565

## What is CVE-2026-42223?

CVE-2026-42223 is a medium-severity vulnerability in 0xJacky nginx-ui, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.8, the GetSettings API handler (api/settings/settings.go:24-65) serializes all settings structs to JSON and returns them to authenticated users. Many sensitive fields are tagged with protected:"true" - however, this tag is only enforced during writes (via ProtectedFill in SaveSettings) and is completely ignored during reads. This exposes 40+ protected fields including JwtSecret (enabling auth token forgery), NodeSecret (enabling cluster node impersonation), OIDC ClientSecret (enabling OAuth account takeover), and the IP whitelist configuration. This issue has been patched in version 2.3.8.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-42223?

3 open source packages ship an affected version, including github.com/0xJacky/nginx-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/nginx-ui` | Go | All versions | None |
| `github.com/0xJacky/nginx-ui` | Go | All versions | 2.3.8 |
| `github.com/0xJacky/nginx-ui` | Go | All versions | 2.3.8 |

Products: Nginxui Nginx Ui.

## How do I fix CVE-2026-42223?

Upgrade github.com/0xJacky/nginx-ui to 2.3.8 or later.

## Is CVE-2026-42223 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42223 exists.

## Other vulnerabilities in 0xJacky nginx-ui

- [CVE-2026-33032](https://insights.sbomify.com/CVE-2026-33032/): Nginx UI: Unauthenticated MCP Endpoint Allows Remote Nginx Takeover (critical 9.8)
- [CVE-2026-27944](https://insights.sbomify.com/CVE-2026-27944/): Nginx UI: Unauthenticated Backup Download with Encryption Key Disclosure (critical 9.8)
- [CVE-2024-23827](https://insights.sbomify.com/CVE-2024-23827/): Nginx-UI arbitrary file write through the Import Certificate feature (critical 9.8)
- [CVE-2026-107806](https://insights.sbomify.com/CVE-2026-107806/): Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite (critical 9.4)
- [CVE-2026-33026](https://insights.sbomify.com/CVE-2026-33026/): nginx-ui Backup Restore Allows Tampering with Encrypted Backups (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42223 and fix it if it is affected.

What it is: CVE-2026-42223 is a medium-severity vulnerability in 0xJacky nginx-ui, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42223 exists.

Affected packages and fixed versions:
- github.com/0xJacky/nginx-ui (Go): affected all versions; no fix listed
- github.com/0xJacky/nginx-ui (Go): affected all versions; fixed in 2.3.8
- github.com/0xJacky/nginx-ui (Go): affected all versions; fixed in 2.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42223/ (Markdown: https://insights.sbomify.com/CVE-2026-42223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42223
- OSV: https://osv.dev/vulnerability/CVE-2026-42223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42223/
Summaries are generated and may contain mistakes; the official description above is the record.
