# CVE-2026-42224: ipl/web is vulnerable to reflected XSS by malformed search requests

> Attackers can inject malicious JavaScript into Icinga Web via malformed search requests, allowing code execution in the victim's browser context.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-55wf-5m3q-6jjf, openSUSE-SU-2026:10693-1

## What is CVE-2026-42224?

CVE-2026-42224 is a high-severity cross-site scripting vulnerability in Icinga ipl-web, published on 8 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

ipl/web is a set of common web components for php projects. Prior to versions 0.13.1 and 0.10.3, the vulnerability allows an attacker to inject malicious Javascript into a victim's browser to run it in the context of Icinga Web. The victim needs to visit a specifically prepared website and may have no immediate chance to notice any wrongdoing. This issue has been patched in versions 0.13.1 and 0.10.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42224?

4 open source packages ship an affected version, including ipl/web.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ipl/web` | Packagist | All versions | 0.10.3 |
| `ipl/web` | Packagist | All versions | 0.10.3 |
| `ipl/web` | Packagist | From 0.11.0 | 0.13.1 |
| `ipl/web` | Packagist | From 0.11.0 | 0.13.1 |
| `icinga-php-library` | openSUSE:Tumbleweed | All versions | 0.19.2-1.1 |

## How do I fix CVE-2026-42224?

Upgrade ipl/web to a fixed version for your release line: 0.10.3 or 0.13.1.

## Is CVE-2026-42224 being exploited?

There is no known exploitation of CVE-2026-42224 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42224 and fix it if it is affected.

What it is: CVE-2026-42224 is a high-severity cross-site scripting vulnerability in Icinga ipl-web, published on 8 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42224 in the wild and no public exploit code.

Affected packages and fixed versions:
- ipl/web (Packagist): affected all versions; fixed in 0.10.3
- ipl/web (Packagist): affected all versions; fixed in 0.10.3
- ipl/web (Packagist): affected from 0.11.0; fixed in 0.13.1
- ipl/web (Packagist): affected from 0.11.0; fixed in 0.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42224/ (Markdown: https://insights.sbomify.com/CVE-2026-42224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42224
- OSV: https://osv.dev/vulnerability/CVE-2026-42224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42224/
Summaries are generated and may contain mistakes; the official description above is the record.
