# CVE-2026-42225: GnuTLS backend silently skips certificate chain verification when verify_peer is false

> Attackers can bypass TLS certificate verification in PJSIP GnuTLS builds, allowing man-in-the-middle attacks against SIP connections.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 8 May 2026
- **Also known as:** DEBIAN-CVE-2026-42225, GHSA-x2fv-6j6c-pxmx, UBUNTU-CVE-2026-42225

## What is CVE-2026-42225?

CVE-2026-42225 is a high-severity vulnerability in pjsip pjproject, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, on GnuTLS builds, the SIP TLS transport (sip_transport_tls) can accept connections with invalid or untrusted certificates even when the application explicitly enables certificate verification via verify_server = PJ_TRUE or verify_client = PJ_TRUE. This issue has been patched in version 2.17.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-42225?

It affects 1 product.


Products: Teluu Pjsip.

## How do I fix CVE-2026-42225?

Upgrade to a fixed version.

## Is CVE-2026-42225 being exploited?

There is no known exploitation of CVE-2026-42225 in the wild and no public exploit code.

## Other vulnerabilities in pjsip pjproject

- [CVE-2023-38703](https://insights.sbomify.com/CVE-2023-38703/): PJSIP has use-after-free vulnerability in SRTP media transport (critical 9.8)
- [CVE-2022-39269](https://insights.sbomify.com/CVE-2022-39269/): Media transport downgrade from the secure version (SRTP) to non-secure (RTP) in pjsip (critical 9.1)
- [CVE-2026-57161](https://insights.sbomify.com/CVE-2026-57161/): PJSIP: Stack overflow handling Service-Route headers in a registration response (high 8.8)
- [CVE-2026-57162](https://insights.sbomify.com/CVE-2026-57162/): PJSIP: Stack overflow parsing SDP a=crypto attributes (high 8.8)
- [CVE-2026-57163](https://insights.sbomify.com/CVE-2026-57163/): PJSIP: Stack overflow parsing a TLS peer certificate's SubjectAltName in GnuTLS backend (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42225 and fix it if it is affected.

What it is: CVE-2026-42225 is a high-severity vulnerability in pjsip pjproject, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42225 in the wild and no public exploit code.

Affected product: pjsip pjproject. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42225/ (Markdown: https://insights.sbomify.com/CVE-2026-42225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42225
- OSV: https://osv.dev/vulnerability/CVE-2026-42225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42225/
Summaries are generated and may contain mistakes; the official description above is the record.
