# CVE-2026-42226: n8n: Credential Authorization Bypass in dynamic-node-parameters Allows Foreign API Key Replay

> Authenticated users can bypass credential authorization checks to exfiltrate other users' API keys by supplying foreign credential IDs in dynamic node parameter requests.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-r4v6-9fqc-w5jr

## What is CVE-2026-42226?

CVE-2026-42226 is a high-severity missing authorization vulnerability in N8n N8n, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to versions 1.123.33 and 2.17.5, the dynamic-node-parameters endpoints did not verify whether the authenticated caller was authorized to use a supplied credential reference. An authenticated user with access to a shared workflow could supply a foreign credential ID in the request body, causing the backend to decrypt and use that credential in a helper execution path where the caller also controls the destination URL. This allowed the caller to force the backend to authenticate against attacker-controlled infrastructure using a credential belonging to another user, effectively exfiltrating a reusable API key. The issue is not limited to any single node type; any node that resolves credentials dynamically through these endpoints may be affected. This issue has been patched in versions 1.123.33, 2.17.5, and 2.18.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-42226?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.33 |
| `n8n` | npm | All versions | 1.123.33 |
| `n8n` | npm | From 2.17.0 | 2.17.5 |
| `n8n` | npm | From 2.17.0 | 2.17.5 |

Products: N8n N8n.

## How do I fix CVE-2026-42226?

Upgrade n8n to a fixed version for your release line: 1.123.33 or 2.17.5.

## Is CVE-2026-42226 being exploited?

There is no known exploitation of CVE-2026-42226 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42226 and fix it if it is affected.

What it is: CVE-2026-42226 is a high-severity missing authorization vulnerability in N8n N8n, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42226 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.33
- n8n (npm): affected all versions; fixed in 1.123.33
- n8n (npm): affected from 2.17.0; fixed in 2.17.5
- n8n (npm): affected from 2.17.0; fixed in 2.17.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42226/ (Markdown: https://insights.sbomify.com/CVE-2026-42226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42226
- OSV: https://osv.dev/vulnerability/CVE-2026-42226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42226/
Summaries are generated and may contain mistakes; the official description above is the record.
