CVE-2026-42227 n8n: Public API Variables IDOR Allows Cross-Project Secret Disclosure
Authenticated users can read secrets from other projects via IDOR in the public API, requiring enterprise deployments with variables enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42227?
CVE-2026-42227 is a medium-severity missing authorization vulnerability in N8n N8n, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, an authenticated user with a valid API key scoped to variable:list could read variables from projects they are not a member of by supplying an arbitrary projectId query parameter to the public API variables endpoint. The handler queried the variables repository directly without enforcing project membership checks, bypassing the authorization-aware service layer used by the internal enterprise controller. If variables were misused to store sensitive information such as credentials or tokens, they should be rotated immediately. This issue only affects licensed enterprise or team deployments with multiple projects and the variables feature enabled. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.
Weakness: CWE-639
Which versions are affected by CVE-2026-42227?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.32 |
n8n npm | All versions | 1.123.32 |
n8n npm | From 2.0.0 | 2.17.4 |
n8n npm | From 2.0.0 | 2.17.4 |
n8n npm | From 2.18.0 | 2.18.1 |
n8n npm | From 2.18.0 | 2.18.1 |
Products include N8n N8n.
How do I fix CVE-2026-42227?
Upgrade n8n to a fixed version for your release line: 1.123.32, 2.17.4 or 2.18.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-42227 being exploited?
There is no known exploitation of CVE-2026-42227 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-756q-gq9h-fp22.