CVE-2026-42228 n8n: Hijacking of Unauthenticated Chat Execution
Unauthenticated attackers can hijack active chat executions to read prompts and inject input, affecting n8n workflow automation deployments.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42228?
CVE-2026-42228 is a medium-severity missing authorization vulnerability in N8n N8n, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, the /chat WebSocket endpoint used by the Chat Trigger node's Hosted Chat feature did not verify that an incoming connection was authorized to interact with the target execution. An unauthenticated remote attacker who could identify a valid execution ID for a workflow in a waiting state could attach to that execution, receive the pending prompt intended for the legitimate user, and submit arbitrary input to resume or influence downstream workflow behavior. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.
Weakness: CWE-862
Which versions are affected by CVE-2026-42228?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.32 |
n8n npm | All versions | 1.123.32 |
n8n npm | From 2.0.0 | 2.17.4 |
n8n npm | From 2.0.0 | 2.17.4 |
n8n npm | From 2.18.0 | 2.18.1 |
n8n npm | From 2.18.0 | 2.18.1 |
Products include N8n N8n.
How do I fix CVE-2026-42228?
Upgrade n8n to a fixed version for your release line: 1.123.32, 2.17.4 or 2.18.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-42228 being exploited?
There is no known exploitation of CVE-2026-42228 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-f77h-j2v7-g6mw.