# CVE-2026-42229: n8n: SQL Injection in SeaTable Node

> Attackers can inject SQL into SeaTable node operations to retrieve unintended data from connected bases, bypassing workflow filters.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 5 May 2026
- **Also known as:** GHSA-mp4j-h6gh-f6mp

## What is CVE-2026-42229?

CVE-2026-42229 is a medium-severity SQL injection vulnerability in N8n N8n, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, a flaw in the SeaTable node's row:search and row:get operations allowed user-controlled input to be concatenated directly into SQL query strings without escaping or parameterization. In workflows where external user input is passed via expressions into the SeaTable node's search or row retrieval parameters, an attacker could manipulate the constructed query to retrieve unintended rows from the connected SeaTable base, bypassing row-level filtering logic implemented in the workflow. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-42229?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.32 |
| `n8n` | npm | All versions | 1.123.32 |
| `n8n` | npm | From 2.0.0 | 2.17.4 |
| `n8n` | npm | From 2.0.0 | 2.17.4 |
| `n8n` | npm | From 2.18.0 | 2.18.1 |
| `n8n` | npm | From 2.18.0 | 2.18.1 |

Products: N8n N8n.

## How do I fix CVE-2026-42229?

Upgrade n8n to a fixed version for your release line: 1.123.32, 2.17.4 or 2.18.1.

## Is CVE-2026-42229 being exploited?

There is no known exploitation of CVE-2026-42229 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42229 and fix it if it is affected.

What it is: CVE-2026-42229 is a medium-severity SQL injection vulnerability in N8n N8n, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42229 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.32
- n8n (npm): affected all versions; fixed in 1.123.32
- n8n (npm): affected from 2.0.0; fixed in 2.17.4
- n8n (npm): affected from 2.0.0; fixed in 2.17.4
- n8n (npm): affected from 2.18.0; fixed in 2.18.1
- n8n (npm): affected from 2.18.0; fixed in 2.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42229/ (Markdown: https://insights.sbomify.com/CVE-2026-42229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42229
- OSV: https://osv.dev/vulnerability/CVE-2026-42229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42229/
Summaries are generated and may contain mistakes; the official description above is the record.
