CVE-2026-42235 n8n: XSS via MCP OAuth client
An unauthenticated attacker can inject JavaScript via a malicious MCP OAuth client name, leading to session hijacking and privilege escalation in n8n.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-42235?
CVE-2026-42235 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 4 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, an unauthenticated attacker could register a malicious MCP OAuth client with a crafted client_name. If a victim user authorized the OAuth consent dialog and a second user subsequently revoked that access, a toast notification would render the injected script. Clicking the link would execute arbitrary JavaScript in the victim's authenticated n8n browser session, enabling credential and session token theft, workflow manipulation, or privilege escalation. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.
Which versions are affected by CVE-2026-42235?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.32 |
n8n npm | All versions | 1.123.32 |
n8n npm | From 2.17.0 | 2.17.4 |
n8n npm | From 2.17.0 | 2.17.4 |
n8n npm | From 2.18.0 | 2.18.1 |
n8n npm | From 2.18.0 | 2.18.1 |
Products include N8n N8n.
How do I fix CVE-2026-42235?
Upgrade n8n to a fixed version for your release line: 1.123.32, 2.17.4 or 2.18.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-42235 being exploited?
There is no known exploitation of CVE-2026-42235 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-537j-gqpc-p7fq.