CVE-2026-42236 n8n: Unauthenticated Denial of Service via MCP Client Registration
Unauthenticated attackers can cause denial of service in n8n by exhausting server memory via large MCP client registration payloads.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42236?
CVE-2026-42236 is a high-severity denial of service vulnerability in N8n N8n, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, the MCP OAuth client registration endpoint accepted unauthenticated requests and stored client data without adequate resource controls. An unauthenticated remote attacker could exhaust server memory resources by sending large registration payloads, rendering the n8n instance unavailable. The MCP enable/disable toggle gates MCP access but did not restrict client registrations, meaning the endpoint is reachable regardless of whether MCP access is enabled on the instance. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.
Weakness: CWE-770
Which versions are affected by CVE-2026-42236?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.32 |
n8n npm | All versions | 1.123.32 |
n8n npm | From 2.0.0 | 2.17.4 |
n8n npm | From 2.0.0 | 2.17.4 |
n8n npm | From 2.18.0 | 2.18.1 |
n8n npm | From 2.18.0 | 2.18.1 |
Products include N8n N8n.
How do I fix CVE-2026-42236?
Upgrade n8n to a fixed version for your release line: 1.123.32, 2.17.4 or 2.18.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-42236 being exploited?
There is no known exploitation of CVE-2026-42236 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-49m9-pgww-9vq6.