CVE-2026-42237 n8n: SQL Injection in Snowflake and MySQL Nodes
Attackers can inject SQL commands via Snowflake and MySQL nodes in n8n, allowing unauthorized database access and modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42237?
CVE-2026-42237 is a medium-severity SQL injection vulnerability in N8n N8n, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, the fix for GHSA-f3f2-mcxc-pwjx did not cover the Snowflake node or the legacy MySQL v1 node. Both nodes construct SQL queries by directly interpolating user-controlled table names, column names, and update keys into query strings without identifier escaping, enabling SQL injection against the connected database. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.
Weakness: CWE-89
Which versions are affected by CVE-2026-42237?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.32 |
n8n npm | All versions | 1.123.32 |
n8n npm | From 2.0.0 | 2.17.4 |
n8n npm | From 2.0.0 | 2.17.4 |
n8n npm | From 2.18.0 | 2.18.1 |
n8n npm | From 2.18.0 | 2.18.1 |
Products include N8n N8n.
How do I fix CVE-2026-42237?
Upgrade n8n to a fixed version for your release line: 1.123.32, 2.17.4 or 2.18.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-42237 being exploited?
There is no known exploitation of CVE-2026-42237 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-hp3c-vfpm-q4f7.